Home News Hackers Can Target Able2Extract Users With Malicious Image Files

Hackers Can Target Able2Extract Users With Malicious Image Files

20
0

Source: SecurityWeek

Serious vulnerabilities found by researchers in Investintech’s Able2Extract Professional tool can be exploited by hackers to execute arbitrary code using specially crafted image files.

According to Investintech, Able2Extract Professional has over 250,000 licensed users across 135 countries, including in 90% of Fortune 100 companies. The cross-platform tool allows users to view, convert and edit PDF files.

Researchers at Cisco Talos discovered that Able2Extract Professional is affected by two high-severity memory corruption vulnerabilities that can be leveraged to execute arbitrary code on the targeted machine.

The flaws, tracked as CVE-2019-5088 and CVE-2019-5089, can be exploited using specially crafted JPEG or BMP image files that trigger an out-of-bounds memory write. If an attacker can convince the targeted user to open such a file using Able2Extract Professional, they can execute code on the victim’s machine.

Cisco Talos said it reported the vulnerabilities to Investintech in early August and a patch was released on November 1, but it’s unclear which version includes the fix. Talos has reproduced the vulnerabilities on version 14.0.7 x64.

Talos has made available technical details for both vulnerabilities. These types of security holes could be highly useful to attackers given Able2Extract Professional’s large user base.

Able2Extract is not the only PDF tool in which Talos researchers have found vulnerabilities. They have also identified serious flaws in products from Aspose and Foxit.

LEAVE A REPLY

Please enter your comment!
Please enter your name here

78 − = 76